Back

SolaFrame Theatre

  • SolaFrame Theatre firmware versions 1.3.0 and later are not backwards compatible. After you update a fixture to firmware version 1.3.0 or later, you will be unable to upload firmware versions 1.2.10 or earlier to that fixture. For assistance, contact ETC Technical Services at etcconnect.com/contactETC.