Back

Lonestar

  • Lonestar firmware versions 1.4.1 and later are not backwards compatible. After you update a fixture to firmware version 1.4.1 or later, you will be unable to upload firmware versions 1.3.1 or earlier to that fixture. For assistance, contact ETC Technical Services at etcconnect.com/contactETC.

  • Product
    Type
    Language
    Sort By: Date|A - Z