Back
  • Do I need to upgrade the boot rom to run V3.03 on my Express console?

    If you have the newer IO chips (FDC37C665) you would need boot roms running 1.02.

    Most Consoles already have the new ROM code and if you are running v3.0.3 or better now, your console is fine.

    Only the first few systems had the old chips (FDC37C651).

    These can use 1.01. with V3.03.