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Introduction
What is Network Configuration Editor?

ETC’s Network Configuration Editor (NCE) is a spreadsheet-style software 
program designed to make configuring ETCNet2™ DMX and Video nodes 
easy. With NCE you can edit the parameters of any port on any node in an 
ETCNet2 system. Through an Ethernet connection, you can read the 
configuration of any node on the network, edit it offline, and send the 
configuration back to the node via the network for use.

Note: NCE v3.0.x is only compatible with ETCNet2 nodes running version 
3.0.x node software. To update nodes from a previous version of software, 
please read Appendix C- Upgrading Node Software (page 33).

NCE does not work with ETC’s older style Remote Video Interface (RVI), 
Remote Interface Unit (RIU) or with ETCNet2 nodes running in ETCNet1 
mode with Expression® family consoles. If you have questions about the 
type of network you have, please call ETC Technical Services at the office 
nearest you:

ETC Americas . . . . . . . . . . . . . . . . . . . . . . 800/775-4382
ETC Asia . . . . . . . . . . . . . . . . . . . . . . . . +852 2799 1220
ETC Europe . . . . . . . . . . . . . . . . . . . +44 0 20 8896 1000

If you have any comments regarding this manual, please email us at: 
TechComm@etcconnect.com

Emphasis™ Users
Several parts of this manual don’t directly apply to users of NCE on an 
Emphasis Server. All added notes assume that NCE is running on the 
Emphasis Server.

Notes have been added in the relevant topics to let you know how they are 
different for you. Frequently, the changes will be things you don’t need to 
do because Emphasis has already taken care of it. The first of which are 
meeting the minimum requirements below and performing the initial 
installation.

If you are running NCE on an additional PC to your Emphasis system, then 
follow all of the normal instructions.
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Minimum requirements
These minimum requirements are for a personal computer running 
Network Configuration Editor (NCE).

• Pentium® or compatible processor, 266MHz or better

• 32MB RAM

• Screen resolution should be set to 800X600 or greater

• Compatible with Windows® 98, 2000, NT4 (with Service Pack 5 and 
later), XP.

• Microsoft Internet Explorer 5.1 or higher

• Network Interface Card (NIC) capable of 10Mbps transmission speeds 
over UTP cable

Product Definitions
ETCNet2 - ETC’s current Ethernet protocol suite, ETCNet2 supports IP 
addressing that allows the use of off-the-shelf Ethernet hubs and switches 
in networked systems.

ETCNet1 - A proprietary Ethernet based communication protocols used 
with Expression family consoles, Remote Interface Units (RIU’s), Remote 
Video Interfaces (RVI’s) and Obsession® I consoles. Products using these 
protocols are not configurable with NCE.

EDMX™ - Ethernet DMX. On an ETCNet2 network there are 32,767 valid 
EDMX addresses (from 1-32,767) each of which contain level information 
of 0 to 100%.

It is important to note that EDMX does not operate on a Highest Takes 
Precedence (HTP) basis. Instead, it works on an “ownership” scheme 
based on priority levels of individual sources, such as an Emphasis 
system, a Unison® zone or a individual input port on a DMX Node.

Please see Appendix A- ETCNet2™ EDMX™ Rules (page 29) for a 
detailed list of rules that determine how priorities work and what source will 
have control based on individual software configurations.

vPort™ - A vPort is a sequential range of EDMX values assigned a 
numeric label. By default, a vPort contains 512 sequential addresses (and 
their associated EDMX values). See Appendix B- Default vPort™ Table 
(page 31) for a table of vPorts and their default EDMX values.

System - A collection of networked or non-networked ETC devices 
connected via any of a variety of communication protocols for the control 
of a specific geographic area (i.e. Lobby, Theatre, Ballroom, etc.). A 
system may also refer to a specific family of controllers (Obsession II 
system, Expression system, Unison system, etc.) It should be noted that a 
single network may connect several different systems.

Network - A collection of ETCNet1 or ETCNet2 devices connected via a 
common media and communication type such as Category 5 UTP.
ETC, Inc.



ETCNe
Installing NCE
Install Network Configuration Editor (NCE)

Emphasis User: Unless you are upgrading to a more recent version of 
NCE or node software (currently v3.0.0), it is already 
installed for you as part of your base system.

To install the ETCNet2 NCE:

1. Insert the CD-ROM with NCE v3.0.0 on it into the CD-ROM drive on 
your computer.

2. On your desktop, double-click My Computer.
3. Double-click Compact Disc.
4. Double-click the Setup.exe icon for NCE and follow the instructions 

on your screen.
5. Use the default installation location
6. Use the default Setup Type of Typical.
7. Near the end of the install process, a NICPicker window will appear. 

This is to allow to select which Network Interface Card (NIC) you want 
to use with ETCNet2 applications such as NCE. Checkmark the box 
of the one you want to use. If only one NIC is available, use that one.

8. Once you have selected your NIC, choose Save.
9. A Save dialog box will appear. The default directory and file name to 

save your selection is correct. Do not change the location or the 
file name! The file name must be: etcnet2.cfg

10. Click Save.
11. Close NICPicker.
12. Click Finish to complete the NCE installation process.
t2 Network Configuration Editor 5
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There are three additional files that must be installed separately from NCE. 
They contain the dmxnode.bin, vidnode.bin and twoport.bin files for the 
ETCNet2 DMX, Video Nodes and Two Port Nodes respectively.These files 
are self-extracting executable files that are used to update software on 
ETCNet2 nodes and enable the Network Address Server to hand out IP 
address to those node types.

To install the dmxnode.bin, vidnode.bin and twoport.bin files (follow the 
same procedure for each of the files):

13. Double-click the dmx_A3.0.0.9.0.13_R1.0.1_E3.1_T1.3.0.exe file 
(vid_A3.0.0.9.0.12_R1.0.2_E3.1_T1.3.1.exe for the Video Node file).
Note: These file names will change slightly with minor updates to the 
software.

14. Click Unzip.
Note: You must install the .bin files in the default directory. NCE is 
programmed to look in the default directory and will not update nodes 
properly if the .bin files are not stored there.

15. If a dialog box appears asking if it is okay to overwrite the existing 
files, click “Yes”. This will replace a previously installed version of 
node software with the current version.

16. Then click “OK” and “Close”
17. Repeat steps 12 through 15 for the other node types.

Network Settings
Emphasis User: The Emphasis Server network settings are the default 

ETC® values and ready for immediate use. No configura-
tion is required.

IP addresses for ETCNet2 nodes are automatically set by NCE based on 
the IP address of the PC that Network Configuration Editor is installed on. 

You also must set an IP address for any personal computer you plan to use 
on an ETCNet2 network. ETC recommends that the personal computer 
used on an ETCNet2 network is dedicated to that network so changes to 
network settings are kept to a minimum. 

Note: If the computer you wish to use is currently being used on a non-
ETCNet2 network please consult your Network Administrator before 
changing the IP, Subnet Mask or Gateway addresses.

Default Network Settings for your personal computer
Prior to changing any Network settings on your personal computer please 
record the current settings in the following spaces below.

• IP Address _________________

• Subnet Mask _________________

• Gateway _________________
ETC, Inc.



ETCNe
To use your personal computer on an ETCNet2 network that does not use 
a network router (i.e. hub and/or switch only), ETC recommends the 
following default settings:

• IP Address 10.101.1.101

• Subnet Mask 255.255.0.0

• Gateway 10.101.1.101

Note: If you have a network that does include a network router, you must 
set the Gateway address to the appropriate port on the router.

Each additional computer on an ETCNet2 network must have it’s own IP 
address which must be different from any other computer on the same 
ETCNet2 network. Select from the following default range of IP addresses 
for an additional personal computer running NCE:

Bootp.cfg file settings
In NCE version 3.0.0, you should not need the bootp.cfg file unless you are 
running a version of Windows® prior to Microsoft® Windows 98 Second 
Edition. It is still included with this release and will not overwrite your 
bootp.cfg file from a previously installed version of NCE. Read on if you 
think you still need to edit this file.

There is a file installed in the Windows directory that may require user 
intervention. If you use something other than the default IP addresses, the 
bootp.cfg file must be set to match the network settings on your personal 
computer.

To change the bootp.cfg file settings:

1. Using Windows Explorer, browse to the Windows folder (default path 
is C:\windows – or C:\winnt depending on the operating system of the 
machine)

2. Double-click on bootp.cfg (if it does not automatically open in 
Notepad, select Notepad in the Open With dialogue box. Do not 
check the “Always open with...” box).

3. Edit the bootp.cfg file so that the Gateway and the Subnet Mask 
match the Network Settings of your personal computer.

4. Save your changes and close Notepad.

10.101.1.101 10.101.1.113
10.101.1.102 10.101.1.114
10.101.1.103 10.101.1.115
10.101.1.104 10.101.1.116
10.101.1.105 10.101.1.117
10.101.1.106 10.101.1.118
10.101.1.107 10.101.1.119
10.101.1.108 10.101.1.120
10.101.1.109 10.101.1.121
10.101.1.110 10.101.1.122
10.101.1.111 10.101.1.123
10.101.1.112 10.101.1.124
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Note: If you are using default IP Addresses the bootp.cfg file will not need 
to be changed.

Setting the IP address on ETCNet2 Nodes
When ETCNet2 nodes are shipped from the factory, they do not have a 
valid IP address. They must be assigned an IP address via NCE. NCE 
automatically sets the IP address for ETCNet2 nodes via the Network 
Address Server. 

Note: For a node with factory defaults to receive an IP address it must be 
powered on and connected to the network. Connect all nodes to the 
network prior to enabling Network Address Server.

Emphasis User: The Network Address Server within NCE will not function 
on the Emphasis Server. This is because the server 
already has that same functionality running constantly in 
the background. NCE’s Network Address Server knows 
not to duplicate it and will simply not run.

To give DMX and Video nodes IP addresses initially, all 
you have to do is have your Emphasis Server turned on 
and it will happen automatically for you.

Enabling Network Address Server is a two step process, first you must 
connect NCE to the network, then you must enable Network Address 
Server.

To connect NCE to the network:

• Open the Network menu, click Connect.
ETC, Inc.
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To set IP addresses for ETCNet2 DMX and Video nodes:

• Open the Network menu, click Network Address Server

Once Network Address Server is enabled, it will send IP addresses to all 
ETCNet2 nodes (that are currently at factory defaults) on the network. No 
user intervention is required during this process.

On larger networks that employ a network switch or router, the Network 
Address Server resolves IP addresses for nodes on different network 
segments automatically.

Note: Any programmable switch or router to be used on an ETCNet2 
network must be configured prior to using ETCNet2 nodes or Network 
Configuration Editor.

Note: To resolve IP addresses on nodes that currently have an IP address, 
see below.

What to do if a Node has an IP address but the address 
is not compatible with the current network address 
scheme.

It’s possible that you may want to use a node that was previously used on 
a different network. If the IP address for that node is not compatible with 
the address scheme on your network you will need to assign it a new IP 
address.

The following procedure also resolves the IP addresses for a node in the 
event that it has the same IP address as another node already on the 
network. 
t2 Network Configuration Editor 9
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To assign an IP address to a node that already has an IP address:

1. Connect the node in question to the network but do not power it on.
Emphasis User: If this is being performed on an Emphasis Server, then 

you will not need to perform step 2.

2. In NCE, enable Network Address Server.
3. Apply power to the node.
4. The node will take a new IP address that is compatible with the TCP/

IP settings of NCE and the PC it is running on is configured.

Note: Although there is a network function called Reboot Nodes, it will not 
work in this instance because the node you need to reboot has an IP 
address that can not be “seen” by NCE. A node must be configured with a 
valid IP Address for your network and properly connected to NCE and the 
network in order for Reboot Nodes to work.
ETC, Inc.
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Overview
NCE and the ETCNet2 DMX node

NCE allows you to configure the DMX512 and RFU ports on the ETCNet2 
DMX node. Each DMX port may be defined as either an input or an output, 
regardless of the gender of the physical connector.

DMX Input
When a port on the node is configured for Input, the node receives 
DMX512 from an external source and outputs EDMX to the ETCNet2 
network.

DMX Output
When a port is configured for Output, the node receives EDMX channels 
from the ETCNet2 network and outputs DMX512 to a DMX512 device. A 
DMX512 output always starts with DMX 1.

EDMX and vPorts
A vPort’s range of up to 512 EDMX addresses can be assigned 
(sequentially) anywhere in the range of 32,767 addresses allowed on an 
ETCNet2 network. There are 64 default vPorts in NCE. A vPort can be 
assigned to any DMX input or DMX output port on an ETCNet2 network.

Any DMX port may be mapped to specific addresses in the EDMX universe 
of 32,767 values. This is accomplished in one of two ways.

Editing EDMX numbers

When you have a device inputting DMX512 onto a ETCNet2 network 
you will typically have at least two ETCNet2 DMX nodes. One will 
generally serve as a DMX512 input and the other as a DMX512 
output device. Match the EDMX Start values for each port on both 
nodes so that they communicate the correct values.

Editing EDMX numbers is the most flexible manner of numbering but 
can make for a lot of bookkeeping due to the large numbers involved.

Using vPorts

A vPort is a range of EDMX values assigned a numeric label. Once 
your vPorts are set up, you can assign them to physical ports without 
having to edit EDMX addresses on a port by port basis.

EDMX consists of 32,767 addresses. A vPort is a collection of up to 
512 sequential addresses that can be placed anywhere within that 
range.

Each of the 512 possible addresses in a vPort is an EDMX value. In a 
default configuration, vPort 1 = EDMX addresses 1-512, vPort 2 = 
EDMX addresses 513-1024 and so on.

Note: NCE defaults to having 64 vPorts. Additional vPorts can be 
created and will start with vPort 65.
t2 Network Configuration Editor 11
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Status
Getting Started
There are two approaches to creating a configuration in Network 
Configuration Editor. The first is to create a configuration for each node 
from scratch and then download the configuration to the nodes. A second, 
faster and easier approach is to install your network with all of the nodes 
and then use the Get Unbound Nodes command in NCE. This is used to 
get the existing factory default configurations from your nodes and begin 
building from there.

Building Configurations
To use the Get Unbound Nodes command you must have all nodes 
installed on the network and also have your personal computer properly 
configured.

Once your nodes are installed and your personal computer’s IP address is 
set, you’re ready to begin building a configuration.

Connect to the network
Once you’ve opened NCE you must first connect your PC to the network.

To connect your PC to the network:

• On the Network menu, click Connect.

Note: The status bar along the bottom of the window shows information 
about devices on the network and whether or not your PC is connected.

On the status bar: 
Nodes = the number of nodes in the configuration.
Nodes Online = the number of nodes on the network.
Network: Online = PC is connected to the network.
Network: Offline = PC is not connected to the network.

 Bar
t2 Network Configuration Editor 13
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Get Unbound Nodes
Build a new configuration file from nodes already on the network by using 
the Get Unbound Nodes command. When you start with a blank 
configuration, this command will add any nodes on the network to your 
configuration as new nodes. This command will also add new nodes to an 
existing configuration. You must be connected to the network to get a 
configuration file from a node.

To get the configuration files from unbound nodes:

• On the Network menu, click Get Unbound Nodes.

• Click “Yes” when prompted.

Once the unbound nodes appear in your configuration file, proceed with 
editing parameters of the nodes. When the configuration is complete, send 
the configuration to the nodes to complete the process.

Other Network commands
Send a Configuration to a Node

Use the Send Config to Nodes command to update a node on the 
network with a configuration from your pc. Configuration file nodes must 
be bound to network nodes before sending a configuration to a node.

• On the Network menu, click Send Config to Nodes.

Note: To get a config from a specific node, highlight the node (or nodes) 
by clicking (or control-clicking to select multiple nodes) in the Node Index 
column and follow the same procedure.

Read a Configuration from a Node
Use the Get Config from Nodes command to update an existing 
configuration file. Configuration file nodes must be bound to network 
nodes to be able to get a configuration from a node.

To get the configuration from a node:

• On the Network menu, click Get Config from Nodes.

Note: To get a config from a specific node, highlight the node (or nodes) 
by clicking (or control-clicking to select multiple nodes) in the Node Index 
column and follow the same procedure.
ETC, Inc.
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Binding Nodes
If you’ve created the configuration offline you must bind the nodes in your 
configuration file to the physical nodes on the network. When planning 
your network, keep track of the MAC address’s of your nodes. Use the 
MAC address to identify your nodes when working in the Bind Nodes 
display.

To bind configuration file nodes to physical nodes:

• On the Network menu, click Bind.

• In the Bind Nodes window, click a node in the Configuration File 
Nodes window and the corresponding node in the Network Nodes 
window, click Bind.

Discover Nodes
The Discover Nodes function switches any ETCNet2 node running in 
ETCNet1 mode into ETCNet2 mode (i.e. a node previously connected to 
an Expression family console).

Note: Discover Nodes does not allow ETCNet1 devices (ETCNet Remote 
Interface Unit or ETCNet Remote Video Interface) to operate in ETCNet2 
mode.

To set all nodes on the network in ETCNet1 mode to ETCNet2 mode:

• Reset all nodes by either using the power switch on the front of the 
Video Node or by unplugging power and reconnecting power.

• On the Network menu, click Discover Nodes.

Reboot Nodes
The Reboot Nodes feature is used in the event that you want to reboot 
your nodes remotely.

To reboot all nodes:

• On the Network menu, click Reboot Nodes.
t2 Network Configuration Editor 15
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Note: To reboot a specific node, highlight the node (or nodes) by clicking 
(or control-clicking to select multiple nodes) in the Node Index column and 
follow the same procedure.

Clear Configuration
The Clear Configuration feature is used to restore the factory defaults to 
any nodes selected. It is password protected to prevent its accidental use.

Clear Configuration is reserved for use only at the direction of ETC 
Technical Services.

Update Node Software
To update node software you must first enable Network Address Server. 
Once Network Address Server is enabled you can update node software.

Emphasis User: All you need to do is select Update Node Software as the 
function of the Network Address Server is already being 
performed in the backgound. See next entry for Network 
Address Server for more details.

To update Software in all Nodes:

• On the Network menu, click Network Address Server.

• On the Network menu, click Update Node Software.

Note: To update software for a specific node, highlight the node (or nodes) 
and follow the same procedure.

Note: To update node software or give out IP addresses via NCE you must 
have the upgrade itself installed on your hard drive. Software upgrades are 
distributed separately from NCE and by default are installed in the 
C:\etc\nodesbin directory. Do not change this directory! When you run 
Update Node Software, the Network Address Server looks in this 
directory for node software.

Network Address Server
Emphasis User: The Network Address Server within NCE will not function 

on the Emphasis Server. This is because the server 
already has that same functionality running constantly in 
the background. NCE’s Network Address Server knows 
not to duplicate it and will simply not run.

The Network Address Server is used to download new software to an 
ETCNet2 node or to dynamically assign IP addresses to nodes requesting 
an IP address like nodes that are powering up for the first time.

To enable Network Address Server:

• On the Network menu, click Network Address Server.

You will know that the Network Address Server is running by seeing the 
message “Bootp Started” displayed in the lower-left corner of the NCE 
window on the status bar. You can also check by clicking on the Network 
menu and seeing a checkmark in front of Network Address Server.
ETC, Inc.
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Basic Configurations
NCE is designed to make configuring an ETCNet2 node easy. To meet the 
needs of all types of networks, NCE provides both basic and advanced 
levels of programming for all types of nodes. 

NCE supports four types of ETCNet2 nodes:

• DMX Node

• DMX Node without RFU

• Video Node

• DMX Node Two Port

Note: Fields that are greyed out are not editable based on selected 
parameters.

How to Configure an ETCNet2 DMX node
To configure an ETCNet2 DMX node you must first add a node to your 
configuration or get unbound nodes from the network.

To add a node to a configuration:

• Open the Insert menu and click DMX Node.

The default view shows Node Properties and DMX Port Properties. The 
screen shot below is the left side of the screen and shows Node 
Properties, which has two editable text fields, the Node Name and 
Comment fields.

Text entered in the Name field is stored in the node and will appear each 
time that node is bound to NCE, but text entered in the Comment field is 
only stored in the NCE configuration, not in the node.

To edit Node Name:

• Double-click in the Name field to place a cursor in the field then type 
the name you wish to assign to the node.

Note: Be sure to use names that have meaning to you so that when you 
look at a list of nodes, you can more easily see what you are doing. For 
instance: “Moving Lights in Catwalk 1” is descriptive for both location and 
use.
t2 Network Configuration Editor 17
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DMX Node Two Port
You can name the node and the ports of a 2 port DMX node in NCE and 
have those names appear on the LCD screen of the 2 port node.

To name the node and or ports of the DMX Node 2 port: 

• In the Name field, type the name of the node, the name of port 1 and 
the name of port 2 with each of them separated by a colon ‘:’. For 
example node1:port1:port2.

• There is an additional (fourth) field that can be used to determine the 
state of the LCD backlight on the node. Valid values are “ON” or “OFF”. 
The syntax to enable the backlight is: node1:port1:port2:ON.

Note: If nothing is entered in the Name field, the IP address of the node 
will appear on the LCD screen. If nothing is entered in the Port 1 or Port 2 
portion of the name field, the EDMX start value will be displayed. These 
are the default settings of nodes as they will not have any names until you 
assign them.

DMX Port Properties
The right side of the display shows DMX Port Properties.

The Port column displays the DMX512 port number on your ETCNet2 
DMX node.

Check the box in the Enabled column to activate a DMX port.

Click on Input Output to designate your port as either an input or an 
output. If a port is designated as Input, the Output Port Properties will be 
greyed out and non-editable for that port.

DMX Input Port Properties
When a port on the ETCNet2 DMX node is configured as Input, the port 
receives DMX512 from an external source, such as a console, and outputs 
EDMX onto the ETCNet2 network.

To view the properties of a DMX input port:

• On the View menu, select DMX Inputs.

Port

Enabled

Input Output
ETC, Inc.
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The number entered in the DMX Start column is the first DMX channel that 
the DMX Input port listens to. 

The number entered in the EDMX Start column is the first EDMX value 
that the DMX Start is mapped to output to the network. Valid numbers 
range from 1-32,767.

Enter a number between 1-512 in the EDMX Channels column to 
designate the number of EDMX channels you want to input. An EDMX port 
defaults to 512 channels.

Note: if there are fewer than 512 DMX channels being input, the number 
of EDMX channels will be reduced accordingly.

The EDMX End column will change to reflect the last EDMX channel used 
on the Input port. Changing the DMX Start, DMX Channels, or EDMX Start 
columns will cause the EDMX End column to increment or decrement 
accordingly.

A check mark in the DD column indicates that Dimmer Doubling is 
enabled. When Dimmer Doubling is enabled the number of EDMX 
channels for a port is divided into two ranges of 256 channels.

The DD EDMX Start address column displays the start address of the “B” 
channels on a Dimmer Doubled port.

The DD EDMX End address column displays the end address of the “B“ 
channels on a Dimmer Doubled port.

HLL is an abbreviation for Hold Last Look (Forever). If an ETCNet2 DMX 
node input port loses the DMX stream from its source, the node will 
continue to play the last look for an infinite amount of time when the HLL 
box is checked.

HLL Time is also used in the event of a loss of DMX input. If the HLL box 
is not checked, the node will check to see if an HLL Time is set. If a time 
is set, then the node will hold the last look for the amount of time specified. 
Time is displayed in seconds. The default time is 180 seconds (3 minutes).

Enter a number from 1-64 in the vPort column to use a default set of 512 
EDMX channels. When you specify a vPort, NCE displays the default 
EDMX start address and EDMX end address for that vPort. A table of 
vPorts and their default values is located in Appendix B- Default vPort™ 
Table (page 31) of this manual.

Note: When you assign a vPort, the DMX Start address defaults to 1. 
Changing the DMX Start address to a number other than 1 will clear the 
vPort selection.

Use a Port Priority setting to determine which ports have control of any 
EDMX channels. A valid Port Priority is numbered from 1-20. Port priorities 
are used to establish the relative priority or importance of a DMX port 
based on levels (1 having highest priority, 20 having lowest). When an 
EDMX channel is patched to more than one DMX input port, Port Priority 
determines which DMX port controls that channel. As a rule, DMX Ports 

DMX Start

EDMX Start

EDMX Channels

EDMX End

DD

DD EDXM StartDD EDMX Start

DD EDMX End

HLL

HLL Time

vPort

Port Priority
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with higher priority levels take control of EDMX channels from ports with 
lower priority levels.

Note: An input port will only take control of EDMX values when valid DMX 
is coming into the port.

Line Termination is a property of input ports but can only be enabled in 
the Node Details screen. 

To enable Line Termination: on the View menu select Node Details. 

DMX Output Port Properties
When a port on the ETCNet2 DMX node is configured as Output, the Node 
can receive EDMX from the network and output DMX512 to other DMX512 
compliant devices.

To view the properties of a DMX output port:

• On the View menu, select DMX Outputs.

The number in the EDMX Start column displays the first EDMX address 
assigned to a port. Valid numbers range from 1-32,767.

The number in the EDMX Channels column, enter the number of EDMX 
channels you want assigned to that port. A maximum of 512 EDMX 
channels can be assigned to a port.

The EDMX End column is for display only and shows the last EDMX 
address assigned to a port.

A checkmark in the DD column indicates that Dimmer Doubling is enabled. 
When Dimmer Doubling is enabled the number of EDMX channels for a 
port is divided into two ranges of 256 channels.

The DD EDMX Start address column displays the start address of the “B” 
channels on a Dimmer Doubled port.

The DD EDMX End address column displays the end address of the “B“ 
channels on a Dimmer Doubled port.

Enter a number from 1-64 in the vPort column. Each vPort has a default 
set of 512 EDMX channels. When you specify a vPort, NCE displays the 
EDMX start address and EDMX end address for that vPort. A table of 
vPorts and their default values is located in Appendix A of this manual.

Port Speed is a property of DMX output ports but it can only be accessed 
via the Node Details screen. To change Port Speed: on the View menu 
select Node Details.  Under Port Speed select from Max, Fast, Medium, 
Slow. Refresh rate is (average): Max = 42Hz, Fast = 39Hz, Medium, = 
35Hz, Slow = 30Hz.

HLL is an abbreviation for Hold Last Look (Forever). If an ETCNet2 DMX 
node output port loses the EDMX stream from its source, the node will 

Line 
Termination

EDMX Start

EDMX Channels

EDMX End

DD

DD EDXM StartDD EDMX Start

DD EDMX End

vPort

Port Speed
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continue to play the last look for an infinite amount of time when the HLL 
box is checked.

HLL Time is also used in the event of a loss of EDMX input. If the HLL box 
is not checked, the node will check to see if an HLL Time is set. If a time 
is set, then the node will hold the last look for the amount of time specified. 
Time is displayed in seconds.

When HLL is disabled, check the Data Loss Fade Enabled box to set a 
fade time a DMX port so that if it does lose EDMX the port will fade out.

The Data Loss Fade Time is the amount of time that it takes for a port to 
fade from the last known level to a level of zero if EDMX has been lost.

The Data Loss Port Disable box allows you to determine the state of a 
DMX output port in the event that EDMX input is lost. When this box is 
checked, and there is a loss of EDMX input, the DMX output port is 
disabled. When this box is not checked, and EDMX input is lost, the DMX 
output port goes to zero and continues to output valid DMX512 with zero 
levels on the DMX line until EDMX input is reestablished.

Edit vPort Table
To edit vPorts:

• On the Edit menu, click Edit vPorts.

EDMX values
The default vPort table shows the list of vPort ID numbers in the left-hand 
column. To change the EDMX Start and EDMX Channels for a vPort, click 
in a text box in one of these columns and enter a new value.

Note: If a DMX port (Input or Output) is assigned to that vPort, the EDMX 
values for that port will be updated in the configuration when the vPort is 
updated.

Dimmer Doubling
Dimmer doubling can be enabled in the vPort menu.

A checkmark in the DD column indicates that Dimmer Doubling is enabled. 
When Dimmer Doubling is enabled the number of EDMX channels for a 
port is divided into two ranges of 256 channels.

The DD EDMX Start address column displays the start address of the “B” 
channels on a Dimmer Doubled port.

The DD EDMX End address column displays the end address of the “B“ 
channels on a Dimmer Doubled port.

HLL Time

Data Loss Fade 
Enabled

Data Loss Fade 
Enabled

Data Loss Fade 
Time

Data Loss Port 
Disable
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View menu
There are a number of viewing options available that can be used to get 
specific information about your ETCNet2 nodes.

View DMX Nodes
To get information on DMX nodes, select View DMX Nodes.

To view DMX nodes:

• Open the View menu, click DMX Nodes.

View Video Nodes
To get information about Video nodes, select View Video Nodes.

To view Video nodes:

• Open the View menu, click Video Nodes.

View vPorts
To see what vPorts are used on any current input or output port, select 
View vPorts.

To view vPorts:

• Open the View menu, click vPorts.

View DMX Inputs
To check settings for all of the DMX Input ports in your configuration, select 
View DMX Inputs.

To view DMX Inputs:

• Open the View menu, click DMX Inputs.

View DMX Outputs
To check settings for all of the DMX Output ports in your configuration, 
select View DMX Outputs.

To view DMX Outputs:

• Open the View menu, click DMX Outputs.

View Video Ports
To check settings for all of the Video ports in your configuration, select 
View Video Ports.

To view Video Ports:

• Open the View menu, click Video Ports.
ETC, Inc.
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View RFU Ports
To check settings for any RFU ports in your configuration, select View 
RFU Ports.

To view RFU Ports:

• Open the View menu, click RFU Ports.

View Node Addresses
There are many different types of network addresses used to define a 
node and its functions in an ETCNet2 network. These addresses are 
automatically set by NCE and do not require additional configuration by the 
user.

To see Node addresses:

• On the View menu, click Node Addresses. 

View Node Details
The Node Details window is an expanded view of every parameter of the 
ETCNet2 nodes in your configuration. These parameters are primarily 
used by ETC personnel for diagnostics and troubleshooting.

To see all available parameters of your nodes:

• On the View menu, click Node Details.

Configure an ETCNet2 Video node
To configure an ETCNet2 Video node you must first add a node to your 
configuration. 

To add a node to a configuration:

• On the menu bar, click Insert and click Video Node.

The ETCNet2 Video node is used to provide remote displays of your 
control system. There are 11 properties of a video node that can be edited 
by the user.

Video Port Properties
System ID

The System ID is used in networks where there is more than one 
Emphasis or Obsession II system. Use the System ID to identify which 
system your video ports are connected to.
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Display Number
Select CRT 1-CRT 8 to identify which video ports on the Emphasis system 
or Obsession II system you want the ETCNet2 video node to mimic.

Locked
Enable the Lock feature to lock the properties of a video port so that they 
can only be changed by Network Configuration Editor.

Note: In version 3.0.0 of NCE you must either lock both video ports or 
neither of the video ports. This is due to the fact that currently an 
Obsession II processor and NCE treat video ports slightly differently.

PC Keyboard Port Properties
If a keyboard is connected to a video node you can also set a System ID 
for the keyboard. The System ID is used in networks where there is more 
than one Emphasis or Obsession II system. Use the System ID to identify 
which II system your keyboard is connected to.

RFU Port Properties
ETCNet2 DMX and Video Nodes also support a Remote Focus Unit 
(RFU). There is one property that may be set for an RFU, System ID.

To view the RFU port properties of a video or DMX node:

• On the View menu, click RFU Ports.

System ID
The System ID is used in networks where there is more than one 
Emphasis or Obsession II system. Use the System ID to identify which 
system your RFU port is connected to.

Obsession II Emphasis
Monitor Display Display
CRT 1 User one - CRT 1 - console CRT 1 - console
CRT 2 User one - CRT 2 - console CRT 2 - console
CRT 3 User one - expanded channel display 1
CRT 4 User one - expanded channel display 2
CRT 5 User two - CRT 1 - console
CRT 6 User two - CRT 2 - console
CRT 7 User two - expanded channel display 1
CRT 8 User two - expanded channel display 2
ETC, Inc.
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Remote Macro Properties
The Video Node is capable of taking eight (8) individual closures that will 
fire a user specified macro on an Emphasis system. 

Leading Edge Macro
The Leading Edge Macro number will fire the corresponding macro on the 
Emphasis system with the same System ID. This macro will fire at the 
moment the external closure is closed.

Leading Edge System ID
The System ID is used in networks where there is more than one 
Emphasis system. Use the System ID to identify which system your remote 
macro leading edge trigger is sent to.

Trailing Edge Macro
The Trailing Edge Macro number will fire the corresponding macro on the 
Emphasis system with the same System ID. This macro will fire at the 
moment the external closure is opened or released after being closed.

Trailing Edge System ID
The System ID is used in networks where there is more than one 
Emphasis system. Use the System ID to identify which system your remote 
macro trailing edge trigger is sent to.

Remote Trigger Properties
The Remote Trigger function allows you to program a macro on an 
Emphasis system to send an On or Off signal to the remote macro port on 
a Video Node. This remote dry contact closure can be used to control any 
external device capable of using this type of closure. The Remote Trigger 
has a normally open and normally closed output.

Trigger ID
The Trigger ID is used to identify which remote trigger command this video 
node will respond to. The remote trigger ID must match the remote trigger 
ID set on the controlling Emphasis system.

System ID
The System ID is used in networks where there is more than one 
Emphasis system. Use the System ID to identify which system your remote 
macro leading edge trigger is sent to.
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Advanced Configurations
Creating a DMX Offset

Network Configuration Editor also makes it easy to configure large 
networks with multiple nodes and with more than one console controlling 
the same dimmer rack.

For example, two consoles can send DMX512 levels to a single dimmer 
rack and share certain dimmers by programming offset EDMX addresses 
in Network Configuration Editor. In the following diagram there are two 
consoles controlling a single rack.

In this configuration, the Express console sends DMX512 to Input port 1 
on the ETCNet2 DMX Node and the Insight 3 console sends DMX512 to 
Input port 2. A second ETCNet2 DMX Node is located in the dimmer room 
with port 1 configured as Output.

The parameters for DMX Input port 1 are:

DMX Start = 1
EDMX Start = 1001
EDMX Channels = 24

Continued on next page
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DMX Input Ports
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DMX Cables
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DMX Cable
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1024
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1096

Input
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The parameters for DMX Input port 2 are:

DMX Start = 1
EDMX Start = 1025
EDMX Channels = 72

The parameters for DMX Output port 1 are:

EDMX Start = 1001
EDMX Channels = 96

Note: Certain fields in the above screen shots are minimized so that 
the graphics will fit on the printed page.
ETC, Inc.
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Appendix A- ETCNet2™ EDMX™ Rules
With ETCNet2 v3.0.0, the rules for determining ownership of EDMX 
addresses are complete and straightforward. 

It is important to note that EDMX does not operate on a Highest Takes 
Precedence (HTP) basis. Instead, it works on an “ownership” scheme 
based on priority levels of individual sources, such as an Emphasis 
system, a Unison zone or a individual input port on a DMX Node. 

Only one source can have control over a given EDMX address at a time. 
However, several outputs can all “listen” to a single source.

System “givens”. The first few points are either stating the way things are 
or stating the way they need to be to have a valid network setup.

• There are 22 discreet priority settings within EDMX. The lowest 
number will always be the highest priority. 

• Unison with a zone in “Replace Mode” is equal to priority zero (0).

• DMX Node input ports, Emphasis and Obsession II all have a 
modifiable priority of 1 through 20.

• Unison in “Pass-Through-If-Active” mode is equal to priority 21.

• All devices (ETCNet2 nodes, Emphasis components and so on) must 
have unique IP addresses on the network.

• Emphasis and Obsession II systems must have unique System ID’s on 
the network. This only applies if you have multiple control systems on 
the same network.

• ETCNet2 nodes don’t have System ID’s so they are considered to 
have an ID of zero (0).

• Zero is lower than one.

Arbitration. Who has control?

• The lowest priority value has the highest priority. (1 has a higher 
priority than 2)

• If multiple devices have the same priority, the lowest System ID has 
the highest priority. 

• If two ETCNet2 DMX Nodes have the same priority (and by definition 
the same System ID), the node with the lower IP address will have the 
higher priority.

• If two input ports on a ETCNet2 DMX Node have the same priority (and 
by definition the same IP address), the lowest numbered port has the 
highest priority.
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Appendix B- Default vPort™ Table
Use the default vPort table is for reference when working with NCE. 

vPort EDMX# vPort EDMX# vPort EDMX# vPort EDMX#
1 1-512 17 8,193-8,704 33 16,385-16,896 49 24,577-25,088

2 513-1,024 18 8,705-9,216 34 16,897-17,408 50 25,089-25,600

3 1,025-1,536 19 9,217-9,728 35 17,409-17,920 51 25,601-26,112

4 1,537-2,048 20 9,729-10,240 36 17,921-18,432 52 26,113-26,624

5 2,049-2,560 21 10,241-10,752 37 18,433-18,944 53 26,625-27,136

6 2,561-3,072 22 10,753-11,264 38 18,945-19,456 54 27,137-27,648

7 3,073-3,584 23 11,265-11,776 39 19,457-19,968 55 27,649-28,160

8 3,585-4,096 24 11,777-12,288 40 19,969-20,480 56 28,161-28,672

9 4,097-4,608 25 12,289-12,800 41 20,481-20,992 57 28,673-29,184

10 4,609-5,120 26 12,801-13,312 42 20,993-21,504 58 29,185-29,696

11 5,121-5,632 27 13,313-13,824 43 21,505-22,016 59 29,697-30208

12 5,633-6,144 28 13,825-14,336 44 22,017-22,528 60 30,209-30,720

13 6,145-6,656 29 14,337-14,848 45 22,529-23,040 61 30,721-31,232

14 6,657-7,168 30 14,849-15,360 46 23,041-23,552 62 31,233-31,744

15 7,169-7,680 31 15,361-15,872 47 23,553-24,064 63 31,745-32,256

16 7,681-8,192 32 15,873-16,384 48 24,065-24,576 64 32,257-32,767
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Appendix C- Upgrading Node Software
To upgrade the software in your ETCNet2 nodes, you will need a copy of 
NCE that matches the same version of nodes software. NCE and nodes 
with a major version number difference (2.x.x vs. 3.x.x) will not talk to one 
another. They require the same major version number to communicate 
properly.

Assuming you have nodes running a previous version of software, you 
should have the same version of NCE available as well. If not, you can find 
it on ETC’s website at: www.etcconnect.com under Software Downloads.

To perform the upgrade:

1. Install the version of NCE and node software that you are upgrading 
to. It should install the new node software files over the old node 
software files. When it asks to confirm, click on “OK”.

2. Launch the previous version of NCE.
3. Connect to the network and Get Unbound Nodes.
4. Confirm that all of your nodes are present in the configuration. If not, 

attempt to get them online. Only nodes that are currently online will 
be upgraded.

5. Tell all of the nodes to download new software by selecting Update 
Node Software. Do not start the Network Address Server yet.

6. All of the nodes should drop offline. This should be confirmed by 
seeing that the checkmarks in the Online column are no longer 
checkmarked. The nodes will not reappear online under this version 
of NCE.

7. Close the previous version of NCE.
8. Open the new version of NCE.
9. Connect to the network.
10. Start the Network Address Server. 

Emphasis User: If this is being performed on an Emphasis Server, then 
you will not need to do this step

11. After a couple of minutes, you will start to see the Nodes Online 
counter rise. This is showing you how many nodes have completed 
their software download and are now online under the new version of 
software.

12. Once all of your nodes are online again, Get Unbound Nodes.
13. You should now be ready to use your nodes under the new version of 

software.

If you have missed any nodes in the upgrade process (nodes that were on 
loan to another space, ones you forgot in your equipment locker, etc....), 
you can put them on the network and perform the steps listed above again.
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