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Introduction

What is Network Configuration Editor?
ETC’s Network Configuration Editor (NCE) is a spreadsheet-style software 
program designed to make configuring ETCNet2™ DMX and Video nodes 
easy. With NCE you can edit the parameters of any port on any node in an 
ETCNet2 system. Through an Ethernet connection, you can read the 
configuration of any node on the network, edit it offline, and send the 
configuration back to the node via the network.

Note: NCE is only compatible with ETCNet2 nodes running version 2.0 
node code. 

It does not work with ETC’s older style Remote Video Interface (RVI), 
Remote Interface Unit (RIU) or with ETCNet2 nodes running ETCNet. If 
you have questions about the type of network you have, please call ETC 
Technical Services at the office nearest you:

ETC Americas 800/775-4382

ETC Asia +852 2799 1220

ETC Europe +44 (0)20 8896 1000

Minimum requirements
These minimum requirements are for a personal computer running 
Network Configuration Editor.

• Pentium or compatible processor, 266MHz or better

• 32MB RAM

• Screen resolution should be set to 800X600 or greater

• Compatible with Windows® 95, 98, 2000, NT4 (with Service Pack 5 
and later)
Note: Windows 95 will require the WinSock 2 Update to run NCE. At 
the Microsoft website, search for “Winsock 2 Update”. If you have 
any questions contact ETC Technical Services at one of the above 
numbers.

• Microsoft Internet Explorer 5.0

• Network Interface Card
2 Network Configuration Editor 3
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Installing NCE

Install Network Configuration Editor
To install the ETCNet2 Network Configuration Editor (NCE):

1. Insert the diskette labeled “NCE Disk 1” into the floppy drive on your 
personal computer.

2. On your desktop, double-click My Computer.
3. Double-click 3-1/2 Floppy (A:).
4. Double-click the Setup.exe icon and follow the instructions on your 

screen.
Two additional diskettes are included with the installation that must be 
installed separately from NCE. They contain the DMXNode.bin and 
VidNode.bin files for the ETCNet2 DMX and Video nodes.These files are 
self-extracting executable files that are used to update software on 
ETCNet2 nodes.

To install the DMXNode.bin and VidNode.bin files (follow the same 
procedure for both diskettes):

1. Insert the diskette labeled DMXNode.bin.
2. On your desktop, double-click My Computer.
3. Double-click 3-1/2 Floppy (A:).
4. Double-click the dmx_A2.0.0.9.0.0_R0.0.81_E3.1.exe file 

(vid_A2.0.0.9.0.0_R0.0.81_E3.1.exe for the VidNode.bin disk).
Note: You must install the .bin files in the default directory. NCE is 
programmed to look in the default directory and will not update 
nodes properly if the .bin files are not stored there.

Network Settings
IP addresses for ETCNet2 nodes are automatically set by NCE based on 
the IP address of the PC that Network Configuration Editor is installed on. 
Manual editing of network addresses is password protected.

You also must set an IP address for any personal computer you plan to use 
on an ETCNet2 network. ETC recommends that the personal computer 
used on an ETCNet2 network is dedicated to that network so changes to 
network settings are kept to a minimum. 

Note: If the computer you wish to use is currently being used on a non-
ETCNet2 network please consult your Network Administrator before 
changing the IP, Subnet Mask or Gateway addresses.

Default Network Settings for your personal computer
Prior to changing any Network settings on your personal computer please 
record the current settings in the following spaces below.

• IP Address _________________

• Subnet Mask _________________

• Gateway _________________
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To use your personal computer on an ETCNet2 network that does not use 
a network router (i.e. hub/concentrator only), ETC recommends the 
following default settings:

• IP Address 10.101.1.101

• Subnet Mask 255.255.0.0

• Gateway 10.101.1.101

Note: If you have a network that does include a network router, you must 
set the Gateway address to that router.

Each additional computer on an ETCNet2 network must have it’s own IP 
address which must be different from any other computer on the same 
ETCNet2 network. Select from the following default range of IP addresses 
for an additional personal computer running NCE:

10.101.1.101 10.101.1.113
10.101.1.102 10.101.1.114
10.101.1.103 10.101.1.115
10.101.1.104 10.101.1.116
10.101.1.105 10.101.1.117
10.101.1.106 10.101.1.118
10.101.1.107 10.101.1.119
10.101.1.108 10.101.1.120
10.101.1.109 10.101.1.121
10.101.1.110 10.101.1.122
10.101.1.111 10.101.1.123
10.101.1.112 10.101.1.124
Installing NCE
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Change the bootp.cfg file settings
In NCE version 2.0 there is a file installed in the NCE directory that requires 
configuration. The bootp.cfg file must be set to match the network 
settings on your personal computer.

To change the bootp.cfg file settings:

1. Using Windows Explorer, browse to the NCE folder (default path is 
C:\ETC\EtcNet2 NCE).

2. Double-click on bootp.cfg (if it does not automatically open in 
Notepad, select Notepad in the Open With dialogue box).

3. Edit the bootp.cfg file so that the Gateway and the Subnet Mask 
match the Network Settings of your personal computer.

4. Save your changes and close Notepad.
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Setting the IP address on ETCNet2 Nodes
When ETCNet2 nodes are shipped from the factory, they do not have a 
valid IP address. They must be assigned an IP address via NCE. NCE 
automatically sets the IP address for ETCNet2 nodes via the Network 
Address Server. 

Note: For a node with factory defaults to receive an IP address it must be 
powered on and connected to the network. Connect all nodes to the 
network prior to enabling Network Address Server.

Enabling Network Address Server is a two step process, first you must 
connect NCE to the network, then you must enable Network Address 
Server.

To connect NCE to the network:

• Open the Network menu, click Connect.

To set IP addresses for ETCNet2 DMX and Video nodes:

• Open the Network menu, click Network Address Server

Once Network Address Server is enabled, it will send IP addresses to all 
ETCNet2 nodes (that are currently at factory defaults) on the network. No 
user intervention is required during this process.

On larger networks that employ a network switch or router, the Network 
Address Server resolves IP addresses for nodes on different network 
segments automatically.

Note: Any programmable switch or router to be used on an ETCNet2 
network must be configured prior to using ETCNet2 nodes or Network 
Configuration Editor.

Note: To resolve IP addresses on nodes that currently have an IP address, 
see pp.9.
Installing NCE
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What to do if a Node has an IP address but the address is not 
compatible with the current network address scheme.

It’s possible that you may want to use a node that was previously used on 
a different network. If the IP address for that node is not compatible with 
the address scheme on your network you will need to assign it a new IP 
address.

The following procedure also resolves the IP addresses for a node in the 
event that it has the same IP address as another node already on the 
network. 

To assign an IP address to a node that already has an IP address:

1. Connect the node in question to the network but do not power it on.
2. In NCE, enable Network Address Server.
3. Apply power to the node.
Note: Although there is a network function called Reboot Nodes, it will 
not do anything in this instance because the node you need to reboot has 
an IP Address that can not be “seen” with NCE. A node must be 
configured with a valid IP Address and properly connected to the network 
and NCE in order for Reboot Nodes to work.
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Overview

New Product Definitions
ETCNet2 - ETC’s new Ethernet protocol suite, ETCNet2 supports IP 
addressing that allows the use of off-the-shelf Ethernet hubs and 
switches in networked systems.

EDMX - Ethernet DMX. On an ETCNet2 network there are 32,767 valid 
EDMX addresses (from 1-32,767). 

vPort - A vPort is a sequential range of EDMX values assigned a numeric 
label. By default, a vPort contains 512 sequential addresses (and their 
associated EDMX values). See Appendix A for a table of vPorts and their 
default EDMX values.

System - A collection of networked or non-networked ETC devices 
connected via any of a variety of communication protocols for the control 
of a specific geographic area (i.e. Lobby, Theatre, Ballroom, etc.). A 
system may also refer to a specific family of controllers (Obsession 
system, Expression system, Unison system, etc.) It should be noted that 
a single network may connect several different systems.

Network - A collection of ETCNet1 or ETCNet2 devices connected via 
Ethernet.

NCE and the ETCNet2 DMX node
NCE allows you to configure the DMX512 and RFU ports on the ETCNet2 
DMX node. Each DMX port may be defined as either an input or an output, 
regardless of the sex of the physical connector.

DMX Input
When a port on the node is configured for Input, the node receives 
DMX512 from an external source and outputs EDMX to the ETCNet2 
network.

DMX Output
When a port is configured for Output, the node receives EDMX channels 
from the ETCNet2 network and outputs DMX512 to a DMX512 device.

EDMX and vPorts
A vPort’s group of addresses can be assigned (sequentially) anywhere in 
the range of 32,767 addresses allowed on an ETCNet2 network. There are 
64 default vPorts on an ETCNet2 network. A vPort can be assigned to any 
DMX input or DMX output port on an ETCNet2 network.

Any DMX port may be mapped to specific addresses in the EDMX 
universe of 32,767 values. This is accomplished in one of two ways.
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1. Editing EDMX numbers
When you have a device inputting DMX512 onto a ETCNet2 network 
you will typically have at least two ETCNet2 DMX nodes. One will 
generally serve as a DMX512 input and the other as a DMX512 
output device. Match the EDMX Start values for each port on both 
nodes so that they communicate the correct values.

Editing EDMX numbers is the most flexible manner of numbering but 
can make for a lot of bookkeeping due to the large numbers involved.

2. Using vPorts
vPorts are virtual ports used by NCE that have nothing to do with the 
physical ports found on a DMX node. A vPort is a range of EDMX 
values assigned a numeric label. Once your vPorts are set up, you 
can assign them to physical ports without having to edit EDMX 
addresses.

There are 32,767 addresses in the EDMX universe. A vPort is a 
collection of up to 512 sequential addresses that can be placed 
anywhere within that range.

Each of the 512 addresses in a vPort has an EDMX value associated 
with it. In a default configuration, vPort 1 = EDMX addresses 1-512, 
vPort 2 = EDMX addresses 513-1024 and so on.

Note: NCE defaults to 64 vPorts. Additional vPorts can be created 
and will start with vPort 65.

32,767

EDMX
Universe

1

1001 1512

SR48

Express Console
ETCNet2 DMX Node
DMX Input port

ETCNet2 DMX Node
DMX Output port

EDMX values

DMX cable

DMX cable
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Getting Started
There are two approaches to creating a configuration in Network 
Configuration Editor. The first is to create a configuration for each node 
from scratch and then download the configuration to the nodes. A second, 
easier approach is to install your network with all of the nodes and then 
use the Get Unbound Nodes command in NCE.

Building Configurations
To use the Get Unbound Nodes command you must have all nodes 
installed on the network and also have your personal computer properly 
configured.

Once your nodes are installed and your personal computer’s IP address is 
set, you’re ready to begin building a configuration.

Connect to the network
Once you’ve opened NCE you must first connect your PC to the network.

To connect your PC to the network:

• On the Network menu, click Connect.

Note: The status bar along the bottom of the window shows information 
about devices on the network and whether or not your PC is connected.

On the status bar: 
Nodes = the number of nodes in the configuration.
Nodes Online = the number of nodes on the network.
Network Online = pc is connected to the network.
Network Offline = pc is not connected to the network.

Get Unbound Nodes
Build a new configuration file from nodes already on the network by using 
the Get Unbound Nodes command. When you start with a blank 
configuration, this command will add any nodes on the network to your 
configuration as new nodes. You must be connected to the network to get 
a configuration file from a node.

To get the configuration files from unbound nodes:

• On the Network menu, click Get Unbound Nodes.

Once the unbound nodes appear in your configuration file, proceed with 
editing parameters of the nodes. When the configuration is complete, 
download the configuration to the nodes to complete the process.

Status Bar
2 Network Configuration Editor 13
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Other Network commands
Binding Nodes

If you’ve created the configuration offline you must bind the nodes in your 
configuration file to the physical nodes on the network. When planning 
your network, keep track of the MAC address’s of your nodes. Use the 
MAC address to identify your nodes when working in the Bind Nodes 
display.

To bind configuration file nodes to physical nodes:

1. On the Network menu, click Bind.
2. In the Bind Nodes display, click a node in the Configuration File 

Nodes window and the corresponding node in the Network Nodes 
window, click Bind.

Send a Configuration to a Node
Use the Send Config to Nodes command to update a node on the 
network with a configuration from your pc. Configuration file nodes must 
be bound to network nodes before sending a configuration to a node.

• On the Network menu, click Send Config to Nodes.

Note: To send a config to a specific node, highlight the node (or nodes) 
and follow the same procedure.

Read a Configuration from a Node
Use the Get Config from Nodes command to update an existing 
configuration file. Configuration file nodes must be bound to network 
nodes to be able to get a configuration from a node.

To get the configuration from a node:

• On the Network menu, click Get Config from Nodes.

Note: To get a config from a specific node, highlight the node (or nodes) 
and follow the same procedure.
Getting Started
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Discover Nodes
The Discover Nodes feature sets any ETCNet2 node running in ETCNet1 
mode into ETCNet2 mode (i.e. a node previously connected to an 
Expression console).

Note: Discover Nodes does not allow ETCNet1 devices (ETCNet Remote 
Interface Unit or ETCNet Remote Video Interface) to operate in ETCNet2 
mode.

To set all nodes on the network in ETCNet1 mode to ETCNet2 mode:

• On the Network menu, click Discover Nodes.

Reboot Nodes
The Reboot Nodes feature is used in the event that you want to reboot 
your nodes remotely.

To reboot all nodes:

• On the Network menu, click Reboot Nodes.

Note: To reboot a specific node, highlight the node (or nodes) and follow 
the same procedure.

Update Node Software
To update node software you must first enable Network Address Server. 
Once Network Address Server is enabled you can update node software.

To update Software in all Nodes:

• On the Network menu, click Enable Network Address Server.

• On the Network menu, click Update Node Software.

Note: To update software for a specific node, highlight the node (or 
nodes) and follow the same procedure.

Network Address Server
Enable the Network Address Server to download new software to an 
ETCNet2 node or to dynamically assign IP addresses to new nodes.

To enable Network Address Server:

• On the Network menu, click Network Address Server.
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Basic Configurations
NCE is designed to make configuring an ETCNet2 node easy. To meet the 
needs of all types of networks, NCE provides both basic and advanced 
levels of programming for all types of nodes. 

NCE supports three types of ETCNet2 nodes:

1. DMX Node
2. DMX Node without RFU
3. Video Node
Note: Fields that are greyed out are not editable based on selected 
parameters.

Configure an ETCNet2 DMX node
To configure an ETCNet2 DMX node you must first add a node to your 
configuration or get unbound nodes from the network.

To add a node to a configuration:

• Open the Insert menu and click DMX Node.

The default view shows Node Properties and DMX Port Properties. The 
screen shot below is the left side of the screen and shows Node 
Properties, which has two editable text fields, the Node Name and 
Comment fields.

Text entered in the Name field is stored in the node and will appear each 
time that node is bound to NCE, but text entered in the Comment field is 
only stored in NCE, not in the node.

To edit Node Name:

• Double-click in the Name field to place a cursor in the field then type 
the name you wish to assign to the node.
2 Network Configuration Editor 17
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The right side of the display shows DMX Port Properties.

DMX Port Properties
The Port column displays the DMX512 port number on your ETCNet2 
DMX node.

Check the box in the Enabled column to activate a DMX port.

Click on Input Output to designate your port as either an input or an 
output. If a port is designated as Input, the Output Port Properties will be 
greyed out for that port.

DMX Input Port Properties
When a port on the ETCNet2 DMX node is configured as Input, the port 
receives DMX512 from an external source, such as a console, and outputs 
EDMX onto the ETCNet2 network.

The number entered in the DMX Start column is the first DMX channel 
that the DMX Input port listens to. 

The number entered in the EDMX Start column is the first EDMX value 
output to the network. Valid numbers range from 1-32,767.

Enter a number between 1-512 in the EDMX Channels column to 
designate the number of EDMX channels you want to input. An EDMX 
port defaults to 512 channels.

Note: if there are fewer than 512 DMX channels being input, the number 
of EDMX channels will be reduced accordingly.

The EDMX End column will change to reflect the last EDMX channel used 
on the Input port. Changing the DMX Start, DMX Channels, or EDMX Start 
columns will cause the EDMX End column to increment or decrement 
accordingly.

Enter a number from 1-64 in the vPort column to use a default set of 512 
EDMX channels. When you specify a vPort, NCE displays the default 
EDMX start address and EDMX end address for that vPort. A table of 
vPorts and their default values is located in Appendix A of this manual.

Note: When you assign a vPort, the DMX Start address defaults to 1. 
Basic Configurations
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Changing the DMX Start address to a number other than 1 will clear the 
vPort selection.

Use a Port Priority setting to determine which ports have control of any 
EDMX channels. A valid Port Priority is numbered from 1-20, 1 is the 
highest priority and 20 is the lowest.

Port Priorities are used to establish the relative priority or importance of a 
DMX port based on levels from 1-20 (1 having highest priority, 20 having 
lowest). When an EDMX channel is patched to more than one DMX input 
port, Port Priority determines which DMX port controls that channel. As a 
rule, DMX Ports with higher priority levels take control of EDMX channels 
from ports with lower priority levels.

Note: A port will only take control of EDMX balues when valid DMX is 
coming into the port

DMX Output Port Properties

The number in the EDMX Start column displays the first EDMX address 
assigned to a port. Valid numbers range from 1-32,767.

The number in the EDMX Channels column, enter the number of EDMX 
channels you want assigned to that port. A maximum of 512 EDMX 
channels can be assigned to a port.

The EDMX End column is for display only and shows the last EDMX 
address assigned to a port.

Enter a number from 1-64 in the vPort column. Each vPort has a default 
set of 512 EDMX channels. When you specify a vPort, NCE displays the 
EDMX start address and EDMX end address for that vPort. A table of 
vPorts and their default values is located in Appendix A of this manual.

HLL is an abbreviation for Hold Last Look (Forever). If an ETCNet2 DMX 
node output port loses the EDMX stream from its source, the node will 
continue to play the last look for an infinite amount of time when the HLL 
box is checked.

HLL Time is also used in the event of a loss of EDMX input. If the HLL box 
is not checked, the node will check to see if an HLL Time is set. If a time 
is set, then the node will hold the last look for the amount of time 
specified. Time is displayed in seconds.

The Data Loss Port Disable box is a special feature that allows you to 
determine the state of the DMX output port in the event of a loss of EDMX 
input. When this box is checked, and there is a loss of EDMX input, the 
DMX output port is disabled. When this box is not checked, and EDMX 
input is lost, the DMX output port goes to zero and continues to output 
zeros on the DMX line until EDMX input is reestablished.
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Edit vPort Table
To edit vPorts:

• On the Edit menu, click Edit vPorts.

EDMX values
The default vPort table shows the list of vPort ID numbers in the left-hand 
column. To change the EDMX Start and EDMX Channels for a vPort, click 
in a text box in one of these columns and enter a new value.

Note: If a DMX port (Input or Output) is assigned to that vPort, the EDMX 
values will be updated in the configuration when the vPort is updated.

View menu
There are a number of viewing options available that can be used to get 
specific information about your ETCNet2 nodes.

View Nodes
To get information on Node Properties, and DMX Port Properties 
(including input and output port settings) select View Nodes.

To view Nodes:

• Open the View menu, click Nodes.

View vPorts
To see what vPorts are used on any current input or output port, select 
View vPorts.

To view vPorts:

• Open the View menu, click vPorts.

View DMX Inputs
To check settings for all of the DMX Input ports in your configuration, 
select View DMX Inputs.

To view DMX Inputs:

• Open the View menu, click DMX Inputs.

View DMX Outputs
To check settings for all of the DMX Output ports in your configuration, 
select View DMX Outputs.

To view DMX Outputs:

• Open the View menu, click DMX Outputs.
Basic Configurations
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View Video Ports
To check settings for all of the Video ports in your configuration, select 
View Video Ports.

To view Video Ports:

• Open the View menu, click Video Ports.

View RFU Ports
To check settings for any RFU ports in your configuration, select View 
RFU Ports.

To view RFU Ports:

• Open the View menu, click RFU Ports.

View Node Addresses
There are many different types of network addresses used to define a 
node and its functions in an ETCNet2 network. These addresses are 
automatically set by NCE and do not require additional configuration by the 
user.

To see Node addresses:

• On the View menu, click Node Addresses. 

View Node Details
The Node Details window is an expanded view of every parameter of the 
ETCNet2 nodes in your configuration. These parameters are primarily 
used by ETC personnel for diagnostics and troubleshooting.

To see all available parameters of your nodes:

• On the View menu, click Node Details.
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Configure an ETCNet2 Video node
To configure an ETCNet2 Video node you must first add a node to your 
configuration. 

To add a node to a configuration:

• On the menu bar, click Insert and click Video Node.

The ETCNet2 Video node is used to provide remote displays of your 
control system. There are only two properties of a video node that can be 
edited by the user.

Display Number
Select CRT 1-CRT 8 to identify which video ports on the Obsession II® 
console you want the ETCNet2 video node to mimic.

Locked
Enable the Lock feature to lock the properties of a video port so that they 
can only be changed by Network Configuration Editor.

Note: In version 2.0 of NCE you must either lock both video ports or 
neither of the video ports. This is due to the fact that currently an 
Obsession processor and NCE treat video ports slightly differently.

Monitor Display

CRT 1 User one - CRT 1 - console
CRT 2 User one - CRT 2 - console
CRT 3 User one - expanded channel display 1
CRT 4 User one - expanded channel display 2
CRT 5 User two - CRT 1 - console
CRT 6 User two - CRT 2 - console
CRT 7 User two - expanded channel display 1
CRT 8 User two - expanded channel display 2
Basic Configurations
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Nodes with Remote Focus Unit 
RFU Port Properties

ETCNet2 Video Nodes also support a Remote Focus Unit (RFU). There is 
one property that may be set for an RFU, Multidrop.

To view the RFU port properties of a video or DMX node:

• On the View menu, click RFU Ports.

Multidrop
Enable Multidrop if there is more than one RFU on a single RFU wire run 
to the node. Multidrop must also be enabled on any RFU used in a 
Multidrop configuration. See your Obsession II manual for further details 
regarding Multidrop RFU.
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Advanced Configurations
Creating a DMX Offset

Network Configuration Editor also makes it easy to configure large 
networks with multiple nodes and with more than one console controlling 
the same dimmer rack.

For example, two consoles can send DMX512 levels to a single dimmer 
rack and share certain dimmers by programming offset EDMX addresses 
in Network Configuration Editor. In the following diagram there are two 
consoles controlling a single rack.

In this configuration, the Express console sends DMX512 to Input port 1 
on the ETCNet2 DMX Node and the Insight 3 console sends DMX512 to 
Input port 2. A second ETCNet2 DMX Node is located in the dimmer room 
with port 1 configured as Output.

The parameters for DMX Input port 1 are:

DMX Start = 1
EDMX Start = 1001
EDMX Channels = 24

Continued on next page

EDMX
Universe

1

32,767

ETCNet2 DMX Node
DMX Input Ports

EDMX values
DMX Cables
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SR48

ETCNet2 DMX Node
DMX Output port

Express Console

Insight 3 Console

DMX Cable
1001

1024
1025

1096

Input
Port 1

Input
Port 2
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The parameters for DMX Input port 2 are:

DMX Start = 1
EDMX Start = 1025
EDMX Channels = 72

The parameters for DMX Output port 1 are:

EDMX Start = 1001
EDMX Channels = 96

Note: Certain fields in the above screen shots are minimized so that 
the graphics will fit on the printed page.
Advanced Configurations



ETCNet
Appendix A - Default vPort table
Use the default vPort table is for reference when working with NCE. 

vPort EDMX# vPort EDMX# vPort EDMX# vPort EDMX#

1 1-512 17 8,193-8,704 33 16,385-16,896 49 24,577-25,088

2 513-1,024 18 8,705-9,216 34 16,897-17,408 50 25,089-25,600

3 1,025-1,536 19 9,217-9,728 35 17,409-17,920 51 25,601-26,112

4 1,537-2,048 20 9,729-10,240 36 17,921-18,432 52 26,113-26,624

5 2,049-2,560 21 10,241-10,752 37 18,433-18,944 53 26,625-27,136

6 2,561-3,072 22 10,753-11,264 38 18,945-19,456 54 27,137-27,648

7 3,073-3,584 23 11,265-11,776 39 19,457-19,968 55 27,649-28,160

8 3,585-4,096 24 11,777-12,288 40 19,969-20,480 56 28,161-28,672

9 4,097-4,608 25 12,289-12,800 41 20,481-20,992 57 28,673-29,184

10 4,609-5,120 26 12,801-13,312 42 20,993-21,504 58 29,185-29,696

11 5,121-5,632 27 13,313-13,824 43 21,505-22,016 59 29,697-30208

12 5,633-6,144 28 13,825-14,336 44 22,017-22,528 60 30,209-30,720

13 6,145-6,656 29 14,337-14,848 45 22,529-23,040 61 30,721-31,232

14 6,657-7,168 30 14,849-15,360 46 23,041-23,552 62 31,233-31,744

15 7,169-7,680 31 15,361-15,872 47 23,553-24,064 63 31,745-32,256

16 7,681-8,192 32 15,873-16,384 48 24,065-24,576 64 32,257-32,767
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