Back
  • Mosaic Hardware Compatibility Updated


    Mosaic Hardware Compatibility

    Mosaic show controllers beginning with 009,010,011 underwent a small hardware change due to a parts obsolescence. These controllers cannot run firmware older than 1.10.1.

    The new MSCX2 controller is compatible with Mosaic Designer versions 1.12.0 and 2.1.0 and above.

    Controllers that are loaded with incorrect firmware will need be recovered using the MSC recovery tools.