Back
  • Custom Magic Sheet Fixture Symbols


    Summary

    You may import custom fixture symbols into your show file for use with the Magic Sheets feature.  The image must be in the SVG (Scalable Vector Graphics) format, and you will have to tag the "base" and "outline" layers in order for the selection and fill/outline coloring to work properly.

    Below is a Step-by-Step tutorial for creating a custom fixture symbol from scratch using the popular, free SVG editor Inkscape


    Step-By-Step using Inkscape

    1. Open Inkscape to start creating a new SVG image
    2. File>Document Properties...  to open the document properties dialog
    3. Click on the Background color swatch, and set the background color to solid black 

      Step A 
    4. Set the document size to 80.0 x 100.0 px
    5. Close the document properties dialog
    6. Object>Fill and Stroke to expose the Fill and Stroke color properties pane
    7. View>Zoom>Page to zoom to fit the whole document
    8. Layer>Rename Layer... and rename the current layer to Base
    9. Select the Rectangle tool from the tool bar on the left

    Step B

    1. Click-and-Drag to create a rectangle that fills most of the document
    2. With the rectangle still selected, select the Fill tab in the Fill and Stroke properties pane
    3. Set the Fill color to the following solid color

    Step C

    1. Select the Stroke paint tab, and set the the stroke to none

    Step D

    1. Edit>Copy to copy the selected rectangle
    2. Layer>Add Layer... to add a new layer named "Outline" (Above current), click [Add]
    3. Edit>Paste-In-Place to add the same rectangle to the new Outline layer
    4. Set the Fill color to none

    Step E

    1. Set the Stroke color to solid white

    Step F

    1. Select the Stroke style tab, and set the stroke Width to 4.0

    Step G

    1. You should end up with something like this 

    Step H

    1. Now, we need to tag each layer for Eos...  Edit>XML Editor...
    2. In the XML node editor, select the "Base" layer
    3. In the XML attribute editor on the right, select the id attribute
    4. Below the attribute editor, change the value of the id attribute to etc_symbol_base and click the [Set] button

    Step 1

    1. Select the "Outline" layer and rename its id attribute to etc_symbol_outline

    Step 2

    1. Close the XML Editor dialog, then Edit>Deselect to clear the selection
    2. File>Document Properties... and expand the Resize page to content section
    3. Set each margin to 2.0 px, and click the [Resize page to drawing selection]

    Step 3

    1. File>Save and import into Eos!

    Advanced

    • The only requirement is that you have one root layer tagged etc_symbol_outline and one root layer tagged etc_symbol_base.  Anything that is part of either layer will be drawn in the appropriate color.  For example, you could add another solid rectangle to the outline layer to show the selection better. (example 2)  You can also flip the outline and base layers, if you want the whole fixture to show selection instead instead of the outline. (example 5)
    • NOTE: hiding layers in Inkscape will cause them to be hidden in Eos as well

    Example Images (click to download)

    Example 1 (very simple, result of Step-by-Step tutorial)

    Example 1 very simple

    Example 2 (larger selection indicator)

    Example 3 (alternate dot selection indicator)

    Example 4 (Fixture outline, where you can link the fill color to the channel color)

    Example 5 (entire fixture shows selection state, can you can link outline color to channel color)