Electronic Theatre Controls
Welcome to ETC's Online Community

KnowledgeBase: Congo Client/RVI/Backup will not Connect to Server

Page Details

First published by:
Kelsey Aleckson
on 06-19-2009
Last revision by:
Kelsey Aleckson
on 07-13-2009
0 people found this article useful.

0% of people found this useful
KnowledgeBase: Congo Client/RVI/Backup will not Connect to Server This page is locked to prevent further edits

Filed under: , ,

If there is a problem getting a Congo Client/RVI/Backup to connect to the Server, here are things to check:

  1. Is the network intact? (Ye olde “Is it plugged in, is it turned on?” question, but here specifically regarding network connections and switches…)
  2. Are the units properly IP-Addressed to allow communication across the network?
  3. Are the units all running the same software version? Congo does not play well with multiple versions active on the network at the same time. Also, there’s a difference between a client that won’t connect and a PC that won’t launch the Congo software at all. Not showing the “Connect Client” option means the PC can’t see the Congo server on the wire (check the Firewall settings). Not launching Congo at all may require a reinstall, or may require deeper PC troubleshooting.
  4. Are the units all set to the same “Logical Network” number in the CongoSettings (the settings one accesses from the welcome screen)? Only units with the same logical network number may see each other on the network and connect to each other.
  5. Does the client/RVI have the proper dongle installed? Does it have any dongle installed? (A sure sign that there is no dongle is if the machine only offers Offline operation.) The Client option will only appear if the dongle is programmed to allow client connection, and that machine “sees” a server online. If you haven’t started the server, the client option cannot appear.
  6. Regarding backups, only one backup may be online at a time, and the backup starting option is only shown in two cases – when another server is online first (meaning you have to start the server machine first) or when dedicated roles have been set up and the machine you are currently looking at is the dedicated backup. The startup screen will indicate Startup Backup* when the dedicated role is set and there is no server currently online.
  7. If none of these solves the problem, deeper network settings investigations may need to happen, such as pinging the machines to check that they really can see each other, checking the settings of managed switches and such. Hopefully it won’t get to this point, though, as most connection problems can be sorted out by checking the first 5 items above.

Recent Comments

Leave the first comment for this page.
Powered by Community Server (Commercial Edition), by Telligent Systems