Electronic Theatre Controls
Welcome to ETC's Online Community

Connecting iRFR to Eos/ION/Element offline on a mac.

rated by 0 users
Not Answered This post has 0 verified answers | 18 Replies | 3 Followers

Top 50 Contributor
219 Posts
jpgagnon posted on 08-05-2009 9:42 AM

I just bought the iRFR for my iphone.  I don't have a console near me for some time, but I was under the impression I could use this with the offline software to get a feel for how the iRFR operates.  Is this not true?  I can't seem to get it to connect.  I am running Mac OS 10.5.7 on an Intel macbook.

 

Thanks

JP

 

JP Gagnon High Output, Inc. Portland, ME

All Replies

Top 10 Contributor
1,061 Posts

Hi JP-

This would require Parallels, Bootcamp, or another way of running Windows with the standard Windows Eos Offline. There is no networking in the Mac Offline (yet).

-luke-

Top 50 Contributor
219 Posts

Thanks Luke.  Of course it couldn't be completely mac friendly! LOL.  I will give it a try on paralells.

BTW, does anyone know when ETC will officially support ONLINE Clients for mac?  

 

JP

 

JP Gagnon High Output, Inc. Portland, ME

Top 25 Contributor
407 Posts

Actually, the iRFR should work with native Mac Offline.  In fact, the bulk of development was done using Mac Offline, since the app itself had to be written on a Mac anyway.

Did you remember to open the Eos Family Welcome Screen, and navigate to Settings>RFR and enable the iRFR?

Also, I believe native Mac Client has been spec'd for v1.9.  (v1.8 will be a smaller release, primarily for the Mirror Mode feature)

Chris Mizerak
Software Engineer
Electronic Theatre Controls

Top 10 Contributor
1,061 Posts

My suggestion would be to listen to Chris, and not me. He's far cleverer! I'm going to try it on my Mac, too...

-luke-

Top 50 Contributor
219 Posts

Chris, thanks for the info.  I did have the RFR selected.  It must have soemthing to do with network I am on. I will try this at home where I can mess with network setting more.

 

That's great about the mac online client.  I have a hasp key, but no way to really use it yet.  And my windows version I have in my Paralells is Windows 2000, so I can't get offline to load up in that anymore.  Something missing in the library or something.

 

Luke, let me know if you get it working.

JP Gagnon High Output, Inc. Portland, ME

Top 25 Contributor
407 Posts

Hi JP,

Okay, I have my Mac today and tried this out, and discovered a bug, so you were right all along :)  It turns out the Eos Family Welcome Screen does not enable the iRFR properly.  We will get this fixed for 1.8.

In the meantime, there is a simple workaround.  Open the following configuration file in Text Edit: "\Library\Application Support\ETC\Eos\eos.ini".  Scroll down to the section labeled "[Eos]".  Just under this, add the new line as follows:

[Eos]
EnableTCPRFR=1

Then simply save the file and run the OLE again.

Chris Mizerak
Software Engineer
Electronic Theatre Controls

Top 50 Contributor
219 Posts

Thanks Chris, but I still can't get it to connect.  Should I have to have a small private network setup with just the computer and the iphone?  I wouldn't think it would matter since I am not using a real console. 

 

I have put the line in the file you said and saved it.  I then open up the welcome screen and check the RFR panel and it is not checked.  Should it be checked?  I have tried it both ways and still no go.

JP Gagnon High Output, Inc. Portland, ME

Top 25 Contributor
407 Posts

Hi JP,

The size of the network shouldn't matter.  First, let's check to make sure the OLE is listening for the iRFR...

  1. Start the OLE
  2. In the browser, select Utilities>Diagnostics
  3. In the Diagnostics screen, scroll through the log and you should see the line "TCP RFR Listening on Port X"

Let me know if you see that line, and we can proceed from there :)

Chris Mizerak
Software Engineer
Electronic Theatre Controls

Top 50 Contributor
219 Posts

I am in the ION Offline.

 

TCP RFR PORT 3031 Initialization Erro (8): The bound address is already in use

 

Does that help?

JP Gagnon High Output, Inc. Portland, ME

Top 25 Contributor
407 Posts

Aha!  The iRFR uses port 3031 to communicate with the console (or OLE) and it seems as though port 3031 also happens to be a standard port for on Mac's for "Apple Events".  We will have to change our hard-coded port in the next version.  (Fun Fact: 3031 is the street address for ETC headquarters in Middleton, WI)

More information on "Apple Events" can be found here:

http://docs.info.apple.com/article.html?path=mac/10.4/en/mh896.html

It looks like you can disable that service, and then try the iRFR again.  (It might require a reboot as well...?)

Chris Mizerak
Software Engineer
Electronic Theatre Controls

Top 50 Contributor
219 Posts

Aha!!  That did it!  Thanks so much Chris.  Nice idea on the port #, but maybe it will have to be another # for the future.

 

Now I get to play.

 

Thanks again.

JP

JP Gagnon High Output, Inc. Portland, ME

Top 500 Contributor
40 Posts

Just a note....

 

I was on iTunes today and asked it to check for updates for my apps and the iRFR was one that had the update available.  1.0.30 is the version that I am now running.  Don't know what it was before...

Top 25 Contributor
407 Posts

Hi Jeff,

The previous version was 1.0.26.  This update is to address the issue found here: http://www.etcconnect.com/Community/forums/t/4114.aspx

Apple approved the update for iRFR - Behind the Scenes late Friday, but we are still waiting on approval for iRFR - Light Relief.  Hopefully any day now...

Chris Mizerak
Software Engineer
Electronic Theatre Controls

Not Ranked
4 Posts

I am going to revive this old topic as I'm having the same problem.

 

My MacBook is connected to my wireless hub via my ethernet with the IP address for the router as 10.101.124.101, and for the mac manually set as 10.101.1.101

My iPhone is connected to the wireless network with the static IP of 10.101.125.101

When I load the iRFR, I enter the IP address of the desk as 10.101.90.101, but it cant find the desk.

 

Having read the topic above I have the 'TCP RFR Listening on Port 3031' in the diagnostics window. I also have the 'Enable' button ticked on the setting from the ETC Family Window. What I cant find is the IP setting for the EOS offline to check I'm entering them on my iPhone correct.

 

Please help, as I would love to get to use the iRFR before getting behind the real desk next week.

 

Thanks,

 

Alex

 

 

Page 1 of 2 (19 items) 1 2 Next > | RSS
Powered by Community Server (Commercial Edition), by Telligent Systems